Download a 30-Day free trial

HomeUser Supporterror when installing version 2

error when installing version 2


when i install version 2 on a couple of my windows xp machines i am getting an error when the application starts.


the error says:
An error occurred while connectiong to the monitoring service.
Verify the service is running and then restart the application.


i have checked the services and cannot see and simple server moniotr service and am unsure what service i should be looking for.

whne i review the event log i dont see any errors ether.

helpppppppp :)
Will | email
Mar 6 2007, 02:42 PM
Will,

It looks like the service wasn't installed. Odd that there isn't an error in Event log. Could you try to install it manually, and let me know what error you get?

To install it manually:
c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\InstallUtil.exe <install dir>\SimpleServerMonitor.Service.exe

Thanks,
Marcus
Marcus | email
1 hour, 51 mins since original post
Hi Marcus

that worked a treat!

did i see somewhere that i can also now log to a database? :)

will
Will | email
7 hours, 10 mins since original post
Hi Will,

Great!

>did i see somewhere that i can also now log to a database? :)

That will be in our next release.

Regards,
Marcus
admin (Admin) | email
11 hours, 31 mins since original post
Hi,

I have this same error on Windows Vista 64bit, can you please tell me what I need to do to get it working on here?

Thanks
Jamie
Jamie | email
5 days, 12 hours since original post
Hi Jamie,

c:\windows\Microsoft.NET\Framework64\v2.0.50727\InstallUtil.exe <install dir>\SimpleServerMonitor.Service.exe

Make sure that you start the command prompt with "Run as Administrator" (right click on the command prompt icon).

Regards,
Marcus
admin (Admin) | email
5 days, 12 hours since original post
Marcus,

Thanks for your quick reply, unfortunately it didn't work for me, it came up with an error but I forgot to make a note of it, however I reinstalled by right clicking and selecting run as administrator and it worked fine that time.

Jamie
Jamie | email
6 days since original post
when i install version 2 on a couple of my windows xp machines i am getting an error when the application starts.


the error says:
An error occurred while connectiong to the monitoring service.
Verify the service is running and then restart the application.

When I install the service manually I get the next error:


C:>c:\Windows\Microsoft.NET\Framework\v2.0.50727\InstallUtil.exe "c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe"
Utilidad de instalación de Microsoft (R) .NET Framework, versión 2.0.50727.42
(c) Microsoft Corporation. Reservados todos los derechos.


Ejecutando una instalación de transacción.

Iniciando la fase de instalación dentro de la instalación.
Consulte el contenido del archivo de registro sobre el progreso del ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
El archivo está ubicado en c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.InstallLog.
Instalando ensamblado 'c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe'.
Los parámetros afectados son:
logtoconsole =
assemblypath = c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe
logfile = c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.InstallLog
Excepción al intentar encontrar los instaladores en el ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
System.Reflection.ReflectionTypeLoadException: No se pueden cargar uno o varios tipos requeridos. Recupere la propiedad LoaderExceptions para obtener más información.
Anulando la instalación de c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.

Excepción durante la fase de instalación.
System.InvalidOperationException: No se pueden obtener los tipos de instalador en el ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
Se produjo una excepción interna System.Reflection.ReflectionTypeLoadException con el siguiente mensaje de error: No se pueden cargar uno o varios tipos requeridos. Recupere la propiedad LoaderExceptions para obtener más información..

Iniciando la fase de desinstalación.
Consulte el contenido del archivo de registro sobre el progreso del ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
El archivo está ubicado en c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.InstallLog.
Deshaciendo ensamblado 'c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe'.
Los parámetros afectados son:
logtoconsole =
assemblypath = c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe
logfile = c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.InstallLog
Excepción al intentar encontrar los instaladores en el ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
System.Reflection.ReflectionTypeLoadException: No se pueden cargar uno o varios tipos requeridos. Recupere la propiedad LoaderExceptions para obtener más información.
Anulando la instalación de c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
Excepción durante la fase de retroceso al estado original del instalador System.Configuration.Install.AssemblyInstaller.System.InvalidOperationException: No se pueden obtener los tipos de instalador en el ensamblado c:\Archivos de programa\Simple Server Monitor\SimpleServerMonitor.exe.
Se produjo una excepción interna System.Reflection.ReflectionTypeLoadException con el siguiente mensaje de error: No se pueden cargar uno o varios tipos requeridos. Recupere la propiedad LoaderExceptions para obtener más información..
Excepción durante la fase de instalación de retroceso al estado original. Esta excepción se omitirá y se continuará con el retroceso al estado original. Sin embargo, puede que el equipo no recupere el estado inicial hasta que se haya completado esta fase.

La fase de retroceso al estado original finalizó correctamente.

La instalación con transacciones ha finalizado.
Error de instalación, se han deshecho los cambios.
Bich | email
1 week since original post
Hi Bich,

This error occurs if you install v2.0 over v1.4. Please uninstall the v2.0, delete
c:\Archivos de programa\Simple Server Monitor\
and then reinstalling v2.0.

Let me know if that works.

Marcus
admin (Admin) | email
1 week since original post
I had the same problem as above .. just trying your manual installation path! *Cross fingers*
Ruth | email
1 week, 5 days since original post
Hi Ruth,

Did you run the installer from an administrator account? We are still trying to figure out why the installer isn't installing the service for some users. Also, was there an error message in the Event Log?

Thanks,
Marcus
admin (Admin)
1 week, 5 days since original post
This topic is closed