Download a 30-Day free trial

HomeFAQFrequently Asked QuestionsSystem Requirements

1. System Requirements

Simple Server Monitor will run under Windows XP or later (including all versions of Windows Vista).  It also requires the Microsoft .NET Framework 2.0. The Simple Server Monitor installer will install the framework if it is not present.

This page was: Helpful | Not Helpful